1.18

This is a quick guide to installing 1.18 and Java 17, since clients on 1.16 and below will no longer be officially supported on the server.

Installing 1.18

If you have the official minecraft launcher, just select 1.18 to install it.

If you're using TLauncher, change your release version (bottom bar, at the left of the "Enter the game" button) to release 1.18.1.

Installing Java


First, you'll need to install Java 17. You can download them from these links. You only need one!

Java 17 (32-bit) | Java 17 (64-bit)

If you downloaded your Java version from Oracle, it's still recommend to upgrade to these versions because they have a slight performance increase.

Lagging or having frame rate issues? Check out our performance modpack!